C++007-C++循环结构

2023-10-16 16:46:42 浏览数 (1)

C 007-C 循环结构

在线练习: http://noi.openjudge.cn/ch0104/ https://www.luogu.com.cn/

for循环

循环可以指挥计算机重复去执行某些代码,减少程序的代码量。 循环可以让计算机去尝试所有的可能情况,找出最优的答案。

for循环举例

多次输出版本

代码语言:javascript复制
#include<iostream>
using namespace std;

int main()
{
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;
    cout<<"hello world"<<endl;

    return 0;
}

for循环版本

代码语言:javascript复制
#include<iostream>
using namespace std;

int main()
{
    for(int i = 0;i<10;i  )
    {
        cout<<"hello world"<<endl;
    }

    return 0;
}
for循环格式
代码语言:javascript复制
#include<iostream>
#include<windows.h>
using namespace std;

int main()
{
    for(int i = 10;i>0;i--)
    {
        system("cls");
        cout<<"hello world"<<endl;
        Sleep(1000);
    }

    return 0;
}
题目描述 输出十次手机号

题目描述 输入一个手机号 重复输出十次。

输入 一个手机号。 输出 十次手机号,每个占据一行。 样例输入 13112345678 样例输出 13112345678 …十次 13112345678

代码语言:javascript复制
#include<iostream>
#include<windows.h>
using namespace std;

int main()
{
    //int n;
    long long n; // 手机号码为11位
    cin >>n;
    for(int i = 10;i>0;i--)
    {
        //system("cls");
        cout<<n<<endl;
        //Sleep(1000);
    }

    return 0;
}
题目描述 打印区间内的整数

题目描述 输入m和n,输出m和n之间的所有整数。

输入 整数m 和整数n。 输出 m和n之间的所有整数。 样例输入 1 5 样例输出 1 2 3 4 5

代码语言:javascript复制
#include<iostream>

using namespace std;

int main()
{
    int n,m;
    cin >>m >>n;
    if (m <n)
    {
        for(int i = m; i<=n; i  )
        {
            cout<<i<<endl;
        }
    }
    else
    {
        for(int i = n; i<=m; i  )
        {
            cout<<i<<endl;
        }

    }

    return 0;
}

输出为:

题目描述 打印字符之间的所有字符

题目描述 输入字符m和n,输出打印字符之间的所有字符,包括m和n。

输入 字符m 和字符n。 输出 m和n之间的所有字符。 样例输入 a e 样例输出 a b c d e

代码语言:javascript复制
#include<iostream>

using namespace std;

int main()
{
    char n,m; //字符的本质还是整数
    cin >>m >>n;
    if (m <n)
    {
        for(char i = m; i<=n; i  ) cout<<i<<endl;
    }
    else
    {
        for(char i = n; i<=m; i  ) cout<<i<<endl;
    }

    return 0;
}

输出为:

题目描述 打印区间内符合条件的整数数数量

题目描述 输入整数m和n,输出打印m和n之间的所有3的倍数的整数数量。

输入 范围m 和n。 输出 m和n之间的所有3的整数倍数数量。 样例输入 10 20 样例输出 3

代码语言:javascript复制
#include<iostream>

using namespace std;

int main()
{
    int n,m,s; 
    s = 0;
    cin >>m >>n;
    if (m <n)
    {
        for(int i = m; i<=n; i  )
        {
            if (i%3 ==0) s  ;
        }
    }
    else
    {
        for(int i = n; i<=m; i  )
        {
            if (i%3 ==0) s  ;
        };
    }
    cout<<s<<endl;

    return 0;
}

输出为:

作业

在线练习:

http://noi.openjudge.cn/ch0104/

总结

本系列为C 学习系列,会介绍C 基础语法,基础算法与数据结构的相关内容。本文为C 循环结构的入门课程,包括相关案例练习。

0 人点赞