问题 1083: Hello, world

2023-04-12 14:40:15 浏览数 (1)

题目描述

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入

72 101 108 108 111 44 32 119 111 114 108 100 33

样例输出

Hello, world! 根据Ascall码输出对应字符 虽说是一道水题却着实错了好几次,一直是输出超限…虽然现在也不知道原因,不过总算是对了

代码语言:javascript复制
#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
     int c;
    while(scanf("%d",&c) != EOF){
    printf("%c", c);
     }
    return 0;
}

0 人点赞