我的GIS/CS学习笔记:https://github.com/yunwei37/ZJU-CS-GIS-ClassNotes <一个浙江大学本科生的计算机、地理信息科学知识库 > 还有不少数据结构和算法相关的笔记以及pta题解哦x
给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。
输入格式:
输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4 13005711862 13588625832 13505711862 13088625832 13588625832 18087925832 15005713862 13588625832
输出样例:
13588625832 3
代码语言:javascript复制#include<iostream>
#include<map>
using namespace std;
//使用map in stl:第一次
int main(){
map<string,int> tele;
int n,i;
int max=1;
string t1,t2;
cin>>n;
map<string,int>::iterator tele1;
for(i=0;i<n; i){
cin>>t1>>t2;
if((tele1=tele.find(t1))!=tele.end()){
tele1->second ;
if(tele1->second>max)
max=tele1->second;
}
else
tele.insert(pair<string,int>(t1,1));
if((tele1=tele.find(t2))!=tele.end()){
tele1->second ;
if(tele1->second>max)
max=tele1->second;
}
else
tele.insert(pair<string,int>(t2,1));
}
int count=0;
for(tele1=tele.begin();tele1!=tele.end(); tele1){
if(tele1->second==max&&!count){
cout<<tele1->first<<" "<<max;
count;
}
else if(tele1->second==max)
count;
}
if(count>1)
cout<<" "<<count;
return 0;
}