我的GIS/CS学习笔记:https://github.com/yunwei37/ZJU-CS-GIS-ClassNotes <一个浙江大学本科生的计算机、地理信息科学知识库 > 还有不少数据结构和算法相关的笔记以及pta题解哦x
假设全校有最多40000名学生和最多2500门课程。现给出每个学生的选课清单,要求输出每门课的选课学生名单。
输入格式:
输入的第一行是两个正整数:N(≤40000),为全校学生总数;K(≤2500),为总课程数。此后N行,每行包括一个学生姓名(3个大写英文字母 1位数字)、一个正整数C(≤20)代表该生所选的课程门数、随后是C个课程编号。简单起见,课程从1到K编号。
输出格式:
顺序输出课程1到K的选课学生名单。格式为:对每一门课,首先在一行中输出课程编号和选课学生总数(之间用空格分隔),之后在第二行按字典序输出学生名单,每个学生名字占一行。
输入样例:
10 5 ZOE1 2 4 5 ANN0 3 5 2 1 BOB5 5 3 4 2 1 5 JOE4 1 2 JAY9 4 1 2 5 4 FRA8 3 4 2 5 DON2 2 4 5 AMY7 1 5 KAT3 3 5 4 2 LOR6 4 2 4 1 5
输出样例:
代码语言:javascript复制1 4 ANN0 BOB5 JAY9 LOR6 2 7 ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6 3 1 BOB5 4 7 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 5 9 AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<list>
#include<vector>
using namespace std;
struct student{
char name[5];
int* c;//保存每个学生的选课;
}stu[40001];//对头(学生名字)排序;
int cla[40001][20]={0};//每个学生的课程;
int count[2501]={0};//每门课程的人数;
int cmp(const void *a,const void *b){
return strcmp(((struct student*)a)->name,((struct student*)b)->name);
}
int main(){
int n,k;
scanf("%d %dn",&n,&k);
int i,x,j,c,m,t;
char name[5];
vector<list<int> > a(k 1);
for(i=0;i<n;i ){
scanf("%s %d",name,&x);
strcpy(stu[i].name,name);
stu[i].c=cla[i];
for(j=0;j<x;j ){
scanf("%d",&t);
cla[i][j]=t;
count[t] ;
}
}
qsort(stu,n,sizeof(struct student),cmp);
for(i=0;i<n;i ){
for(j=0;j<20;j )
if(stu[i].c[j]){
a[stu[i].c[j]].push_back(i);
}//转到每个课程的链表;
}
for(i=1;i<=k;i ){
printf("%d %dn",i,count[i]);
list<int>::iterator a1;
for(a1=a[i].begin();a1!=a[i].end(); a1){
printf("%sn",stu[*a1].name);
}
}
return 0;
}