仅用于复习备考。
Problem Description
利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。
Input
分别输入5个int型整数、5个float 型实数、5个long型正整数。
Output
分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。
Sample Input
代码语言:javascript复制11 22 666 44 55
11.11 22.22 33.33 888.88 55.55
1234567 222222 333333 444444 555555
Sample Output
代码语言:javascript复制666
888.88
1234567
函数的重载中,参数列表必须不相同。
代码语言:javascript复制import java.util.Scanner;
class Max
{
static int getMax(int a[])
{
int ans = -1;
for(int i = 0; i < 5; i ) if(a[i] > ans) ans = a[i];
return ans;
}
static float getMax(float b[])
{
float ans = -1;
for(int i = 0; i < 5; i ) if(b[i] > ans) ans = b[i];
return ans;
}
static long getMax(long c[])
{
long ans = -1;
for(int i = 0; i < 5; i ) if(c[i] > ans) ans = c[i];
return ans;
}
}
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int a[] = new int[10];
float b[] = new float[10];
long c[] = new long[10];
for(int i = 0; i < 5; i ) a[i] = sc.nextInt();
for(int i = 0; i < 5; i ) b[i] = sc.nextFloat();
for(int i = 0; i < 5; i ) c[i] = sc.nextLong();
Max max = new Max();
System.out.print(max.getMax(a) "n" max.getMax(b) "n" max.getMax(c) "n");
}
}