PAT 1036.Boys vs Girls(25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
输入格式:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name
, gender
, ID
and grade
, separated by a space, where name
and ID
are strings of no more than 10 characters with no space, gende
r is either F (female)
or M (male)
, and grade
is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
输出格式:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF−gradeM
. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.
输入样例1:
代码语言:javascript复制3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
输出样例1:
代码语言:javascript复制Mary EE990830
Joe Math990112
6
输入样例2:
代码语言:javascript复制1
Jean M AA980920 60
输出样例1:
代码语言:javascript复制Absent
Jean AA980920
NA
题目分析:vector 排序,水题!。
AC代码:
代码语言:javascript复制#include <bits/stdc .h>
using namespace std;
struct stu{
string name;
string id;
int score;
};
vector<stu> female;
vector<stu> male;
bool cmpfemale(stu a, stu b){return a.score > b.score;}
bool cmpmale(stu a, stu b){return a.score < b.score;}
void print(stu a){
cout<<a.name<<" "<<a.id<<" "<<a.score<<endl;
}
int main(){
int n;
scanf("%d", &n);
string name,gender,id;
int score;
for(int i=0; i<n; i){
cin>>name>>gender>>id;
scanf("%d", &score);
stu s;
s.name = name;
s.id = id;
s.score = score;
if(gender[0]=='M'){
male.push_back(s);
}
else{
female.push_back(s);
}
}
sort(male.begin(), male.end(), cmpmale);
sort(female.begin(), female.end(), cmpfemale);
int maxScore, minScore;
bool flag = false;
if(female.size()!=0){
cout<<female[0].name<<" "<<female[0].id<<endl;
maxScore = female[0].score;
}
else{
flag = true;
cout<<"Absent"<<endl;
}
if(male.size()!=0){
cout<<male[0].name<<" "<<male[0].id<<endl;
minScore = male[0].score;
}
else{
flag = true;
cout<<"Absent"<<endl;
}
if(flag)
cout<<"NA"<<endl;
else
cout<<maxScore-minScore<<endl;
return 0;
}