PAT 1030.Travel Plan(30) A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
输入格式:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:
City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.
输出格式: For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
输入样例:
代码语言:javascript复制4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
输出样例:
代码语言:javascript复制0 2 3 3 40
题目分析:dijkstra dfs模板题。
AC代码:
代码语言:javascript复制#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
const int maxv = 510;
const int inf = 0x3fffffff;
struct Node{
int v,dis;
Node(int v, int dis){
this->v = v;
this->dis = dis;
}
};
bool visited[maxv];
int weight[maxv][maxv];
int cost[maxv];
int d[maxv];
int pre[maxv];
vector<Node> G[maxv];
int n,m,st,ed;
void dijkstra(int s){
for(int i=0; i<maxv; i){
pre[i] = i;
cost[i] = 0;
visited[i] = false;
d[i] = inf;
cost[i] = inf;
}
d[s] = 0;
cost[s] = 0;
for(int i=0; i<n; i){
int u=-1,MIN=inf;
for(int j=0; j<n; j){
if(visited[j]==false && d[j]<MIN){
MIN = d[j];
u = j;
}
}
if(u==-1)return ;
visited[u] = true;
for(int j=0; j<G[u].size(); j){
int v = G[u][j].v;
if(visited[v]==false && G[u][j].dis d[u]<d[v]){
d[v] = G[u][j].dis d[u];
cost[v] = weight[u][v] cost[u];
pre[v] = u;
}
else if(visited[v]==false && G[u][j].dis d[u]==d[v]){
if(cost[u] weight[u][v] < cost[v]){
cost[v] = weight[u][v] cost[u];
pre[v] = u;
}
}
}
}
}
void dfs(int v){
if(v==st){
printf("%d ",v);
return;
}
dfs(pre[v]);
printf("%d ",v);
}
int main(){
scanf("%d%d%d%d", &n, &m, &st, &ed);
int u,v,wt,c;
for(int i=0; i<m; i){
scanf("%d%d%d%d",&u,&v,&wt,&c);
G[u].push_back(Node(v,wt));
G[v].push_back(Node(u,wt));
weight[u][v] = c;
weight[v][u] = c;
}
dijkstra(st);
dfs(ed);
printf("%d %dn", d[ed], cost[ed]);
return 0;
}