Copying Books
POJ - 1505
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers. Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < b k-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1 1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.
Output
For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash. If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.
Sample Input
2 9 3 100 200 300 400 500 600 700 800 900 5 4 100 100 100 100 100
Sample Output
代码语言:javascript复制100 200 300 400 500 / 600 700 / 800 900 100 / 100 / 100 / 100 100
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX_M=500;
int m,k;
int p[MAX_M];
bool flag[MAX_M];
int cnt;
int can(int x)
{
cnt=1;
int sum=0;
memset(flag,false,sizeof(flag));//必须每次都初始化,因为上次判断的不是想要的结果,所以需要重新初始化
for(int i=m-1;i>=0;i--)
{//先满足后面的,从后往前找
sum =p[i];
if(sum>x)
{
cnt ;
sum=p[i];//对cnt重新赋值
flag[i]=true;
}
}
return cnt;
}
void print()
{
cout<<p[0];
for(int i=1;i<m;i )
{
if(flag[i-1])
cout<<" /";
cout<<" "<<p[i];
}
cout<<endl;
}
int main()
{
int n;
int l,r;
cin>>n;
while(n--)
{
cin>>m>>k;
l=r=0;
for(int i=0;i<m;i )
{
cin>>p[i];
if(p[i]>l) l=p[i];//l是页数中的最大值
r =p[i];//r是连续和
}
int mid;
while(l<r)
{
mid=(l r)/2;
if(can(mid)<=k) r=mid;//可以分给的人数太少,那么每个人应该少分一点,右端点向左
else l=mid 1;//否则,可以分给的人数太多,左端点向右
}
int cnt=can(r);//此时得到的cnt一定是小于等于k
for(int i=0;i<m;i )
{
cout<<flag[i]<<" ";
}
cout<<endl<<cnt<<endl;
for(int i=0;i<m&&cnt<k;i )
{//最后cnt一定会等于k
if(!flag[i])
{//flag为false
flag[i]=true;
cnt ;
}
}
print();
}
return 0;
}