HDOJ1021题 Fibonacci Again 应用求模公式

2021-01-19 11:46:42 浏览数 (1)

Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) F(n-2) (n>=2).

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input 0 1 2 3 4 5

Sample Output no no yes no no no

应用求模公式 (1) (a b) % p = (a % p b % p) % p (2) (a - b) % p = (a % p - b % p) % p (3) (a * b) % p = (a % p * b % p) % p (4) a ^ b % p = ((a % p)^b) % p 如果不用的话会溢出。 代码:

代码语言:javascript复制
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
using namespace std;

int main()
{
    int a[1000001],i,j,s;
    a[0]=7;a[1]=11;
    for(i=2;i<1000001;i  )
    {
        a[i]=(a[i-1]%3 a[i-2]%3)%3;//只写最后那个%3也可以
    }
    while(~scanf("%d",&s))
    {
        if(a[s]%3==0)
            printf("yesn");
        else
            printf("non");
    }
    return 0;
}

0 人点赞