HDOJ 1001Sum Problem

2021-01-19 15:01:17 浏览数 (1)

Problem Description Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 2 3 … n.

Input The input will consist of a series of integers n, one integer per line.

Output For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input 1 100

Sample Output 1

5050

代码语言:javascript复制
import java.util.*;
class Main{
  public static void main(String args[]){
    Scanner sc = new Scanner(System.in);
    while(sc.hasNext()){
      int n = sc.nextInt();
      int sum=0;
      for(int i=1;i<=n;i  )
        sum =i;
      System.out.println(sum);
      System.out.println();
  }
  }

}

0 人点赞