Description
Consider the natural numbers from 1 to N. By associating to each number a sign ( or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.
For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem. Input
The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained. Output
The output will contain the minimum number N for which the sum S can be obtained. Sample Input
12 Sample Output
7
第一次知道了,打表法原来也是要消耗时间的,只是相对少些; 还有,用scanf输入比用cin输入要节约时间;scanf是格式化输入,printf是格式化输出。 cin是输入流,cout是输出流。效率稍低,但书写简便。 格式化输出效率比较高,但是写代码麻烦。 流输出操作效率稍低,但书写简便。 cout之所以效率低,是先把要输出的东西存入缓冲区,再输出,导致效率降低。
代码语言:javascript复制#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXX 100010
using namespace std;
int a[MAXX];
void aa()
{
a[0]=0;
for(int j=1; j<=MAXX; j )
{
a[j]=a[j-1] j;
}
}
int main()
{
aa();
int n;
scanf("%d",&n);
int k;
for(int j=1;j<n; j )
{
if(a[j]>=n)
{
k=a[j]-n;
if(k%2==0)
{
printf("%dn",j);
return 0;
}
}
}
return 0;
}