Problem Description 输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input 输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output 对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input qwe asd zxc
Sample Output e q w a d s c x z
代码语言:javascript复制import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
String str = sc.next();
// System.out.println("str=" str);
char[] a = str.toCharArray();
for(int i=0;i<str.length()-1;i ){
for(int j=i 1;j<str.length();j ){
if(a[j]<a[i]){
char temp=a[i];
a[i]=a[j];
a[j] = temp;
}
}
}
System.out.print(a[0]);
for(int i=1;i<a.length;i ){
System.out.print(" " a[i]);
}
System.out.println();
}
}
}