Problem Description Give you the width and height of the rectangle,darw it.
Input Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output For each case,you should draw a rectangle with the width and height giving in the input. after each case, you should a blank line.
Sample Input 3 2
代码语言:javascript复制Sample Output
---
| |
| |
---
别忘了每一个输出后面空一行
代码语言:javascript复制import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int m = sc.nextInt();
int n = sc.nextInt();
for(int i=0;i<n 2;i ){
for(int j=0;j<m 2;j ){
if(i==0){
if(j==0||j==m 1){
System.out.print(" ");
}else{
System.out.print("-");
}
}else if(i==n 1){
if(j==0||j==m 1){
System.out.print(" ");
}else{
System.out.print("-");
}
}else {
if(j==0||j==m 1){
System.out.print("|");
}else{
System.out.print(" ");
}
}
}
System.out.println();
}
System.out.println();
}
}
}