HDOJ 2054 A == B ?(精确大数相等)

2021-01-20 16:19:14 浏览数 (1)

Problem Description Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input each test case contains two numbers A and B.

Output for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input 1 2 2 2 3 3 4 3

Sample Output NO YES YES NO

代码语言:javascript复制
import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            BigDecimal A = sc.nextBigDecimal();
            BigDecimal B = sc.nextBigDecimal();

            if(A.compareTo(B)==0){
                System.out.println("YES");
            }else{
                System.out.println("NO");
            }
        }

    }

}

0 人点赞