HDOJ 2057 A + B Again

2021-01-20 16:19:50 浏览数 (1)

Problem Description There must be many A B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it !

Input The input contains several test cases, please process to the end of the file. Each case consists of two hexadecimal integers A and B in a line seperated by a blank. The length of A and B is less than 15.

Output For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input A -A 1A 12 1A -9 -1A -12 1A -AA

Sample Output 0 2C 11 -2C -90

代码语言:javascript复制
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            long str1 = sc.nextLong(16);
            long str2 = sc.nextLong(16);
            long a = str1 str2;
            if(a<0){
                //System.out.println(a);
                a=-a;
                //System.out.println(a);
                System.out.println("-" Long.toHexString(a).toUpperCase());
            }else{
                System.out.println(Long.toHexString(a).toUpperCase());
            }
        }
    }

}

0 人点赞