Problem Description 给定两个正整数,计算这两个数的最小公倍数。
Input 输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
Output 对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
Sample Input 10 14
Sample Output 70
代码语言:javascript复制import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int a = sc.nextInt();
int b = sc.nextInt();
if(a<b){
a = a^b;
b = a^b;
a = a^b;
}
int a1=a;
int b1=b;
//System.out.println(a " " b);
int t=b;//288 123
while(true){
b = a%b;
a=t;
t=b;
if(b==0){
break;
}
}
//求最大公约数
System.out.println(a1/a*b1);
}
}
}