HDOJ 2092 整数解(2次方程整数解公式)

2021-01-21 14:20:34 浏览数 (1)

Problem Description 有二个整数,它们加起来等于某个整数,乘起来又等于另一个整数,它们到底是真还是假,也就是这种整数到底存不存在,实在有点吃不准,你能快速回答吗?看来只能通过编程。 例如: x y = 9,x * y = 15 ? 找不到这样的整数x和y 1 4=5,1*4=4,所以,加起来等于5,乘起来等于4的二个整数为1和4 7 (-8)=-1,7*(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8

Input 输入数据为成对出现的整数n,m(-10000 < n,m<10000),它们分别表示整数的和与积,如果两者都为0,则输入结束。

Output 只需要对于每个n和m,输出“Yes”或者“No”,明确有还是没有这种整数就行了。

Sample Input 9 15 5 4 1 -56 0 0

Sample Output No Yes Yes

思路: n是两根之和,m是两根之积, {x y = n,x * y = m} =>y^2-ny m=0; 因为y肯定是整数,所以问题简化: 判断y^2-ny m=0是否有【整数解】即可,非整数解和无解都是No

代码语言:javascript复制
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int m = sc.nextInt();
            if(n==0&&m==0){
                return ;
            }
            int s = n*n-4*m;
            int t=(int)Math.sqrt(s);
            if(t*t==s){
                System.out.println("Yes");
            }else{
                System.out.println("No");
            }
        }
    }

}

0 人点赞