HDOJ 1076 An Easy Task(闰年计算)

2021-01-21 14:25:12 浏览数 (1)

Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains two positive integers Y and N(1<=N<=10000).

Output For each test case, you should output the Nth leap year from year Y.

Sample Input 3 2005 25 1855 12 2004 10000

Sample Output 2108 1904 43236

Hint: We call year Y a leap year only if (Y%4==0 && Y0!=0) or Y@0==0.

题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年, 如果year是闰年,则算第一个闰年。

直接暴力做,并没有超时。

代码语言:javascript复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int year = sc.nextInt();
            int n = sc.nextInt();
            int nyear = 0;
            if((year%4==0&&year0!=0)|(year@0==0)){
                nyear=1;
            }//如果year是闰年,nyear就加一
            while(nyear<n){//当nyear小于n时,就循环
                year  ;
                if((year%4==0&&year0!=0)|(year@0==0)){
                    nyear  ;
                }//year是闰年,nyear就加加
            }
            System.out.println(year);
        }
    }

}

0 人点赞