HDU1213 (并查集)

2020-10-23 15:13:34 浏览数 (1)

题意描述

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input 2 5 3 1 2 2 3 4 5

5 1 2 5

Sample Output 2 4

思路

这道题最终的目的是求出有几个不同的集合,所以在合并完集合以后,我们将每个祖宗结点都放进set里面,最后直接输出set的size值即可

AC代码

代码语言:javascript复制
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<map>
#include<set>
#define IOS ios::sync_with_stdio(false); cin.tie(0);
using namespace std;
typedef pair<string,int> PII;
typedef long long ll;
const int N=1010;
int p[N];
int n,m; 
int find(int x){
	if(p[x]!=x) p[x]=find(p[x]);
	return p[x];
}
int main(){
	IOS;
	int T;
	cin>>T;
	while(T--){
		cin>>n>>m;
		memset(p,0,sizeof p);
		for(int i=1;i<=n;i  ){
			p[i]=i;
		}
		while(m--){
			int a,b;
			cin>>a>>b;
			p[find(a)]=find(b);
		}
		set<int> ans;
		for(int i=1;i<=n;i  ) ans.insert(p[find(i)]);
		cout<<ans.size()<<endl;
	}
	return 0;
}

0 人点赞