1745 Divisibility

2020-10-28 10:11:28 浏览数 (1)

Divisibility

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 14084 Accepted: 4989 Description

Consider an arbitrary sequence of integers. One can place or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 5 -21 15 = 16 17 5 -21 - 15 = -14 17 5 - -21 15 = 58 17 5 - -21 - 15 = 28 17 - 5 -21 15 = 6 17 - 5 -21 - 15 = -24 17 - 5 - -21 15 = 48 17 - 5 - -21 - 15 = 18 We call the sequence of integers divisible by K if or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17 5±21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers. Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it’s absolute value. Output

Write to the output file the word “Divisible” if given sequence of integers is divisible by K or “Not divisible” if it’s not. Sample Input

4 7 17 5 -21 15 Sample Output

Divisible Source

Northeastern Europe 1999

这是简单DP水题,WA了几次,初学的时候这个题还是有必要看看!!

代码语言:javascript复制
#include <cstdio> 
#include <iostream>
#include <cstring>
#include <algorithm>
#include <map>
#include <cstdlib>
using namespace std;
#define mod(a) (a)<0? (-(a))%k:(a)%k  
#define mem(a,b) memset((a),(b),sizeof(a));
int dp[10005][105];	
	int a[10005];

int main(){
//	freopen("test.txt","r",stdin);
	mem(dp,0);
	int n,k;
	cin>>n>>k;
	for(int i=1;i<=n;i  )
		cin>>a[i];
	dp[1][mod(a[1])]=1;
	for(int i=2;i<=n;i  )
		for(int j=0;j<k;j  )
			if(dp[i-1][j])
			{
				dp[i][mod(j a[i])]=1;
				dp[i][mod(j-a[i])]=1;
			}
	if(dp[n][0]) cout<<"Divisible";
	else cout<<"Not divisible";
    return 0;}

0 人点赞