Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. Write a program that: reads the number of intervals, their end points and integers c1, ..., cn from the standard input, computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, writes the answer to the standard output.
Input
The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i 1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai 1.
Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.
Sample Input
代码语言:javascript复制5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
Sample Output
代码语言:javascript复制6
代码语言:javascript复制#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn= 50000 10;
const int maxm=500000 10;
#define INF 1e9
struct Edge
{
int from,to,dist;
Edge(){}
Edge(int f,int t,int d):from(f),to(t),dist(d){}
};
struct SPFA
{
int n,m;
int head[maxn],next[maxm];
Edge edges[maxm];
int d[maxn];
bool inq[maxn];
void init()
{
m=0;
memset(head,-1,sizeof(head));
}
void AddEdge(int from,int to,int dist)
{
edges[m]=Edge(from,to,dist);
next[m]=head[from];
head[from]=m ;
}
int spfa()
{
memset(inq,0,sizeof(inq));
for(int i=0;i<n;i ) d[i]= i==0?0:INF;
queue<int> Q;
Q.push(0);
while(!Q.empty())
{
int u=Q.front(); Q.pop();
inq[u]=false;
for(int i=head[u];i!=-1;i=next[i])
{
Edge &e=edges[i];
if(d[e.to]>d[u] e.dist)
{
d[e.to]=d[u] e.dist;
if(!inq[e.to])
{
inq[e.to]=true;
Q.push(e.to);
}
}
}
}
return d[n-1]-d[9];
}
}SP;
int main()
{
int n,max_v=-1;
scanf("%d",&n);
SP.init();
while(n--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
b =10,a =10;//所有值都加10了,以免a-1成为-1
max_v=max(max_v,b);
SP.AddEdge(b,a-1,-c);
}
for(int i=10;i<=max_v;i )//从该循环可看出,本差分约束的点编号为:[9,max_v](未包含超级源0号点)
{
SP.AddEdge(i,i-1,0);
SP.AddEdge(i-1,i,1);
SP.AddEdge(0,i,0);
}
SP.AddEdge(0,9,0);
SP.n=max_v 1;
printf("%dn",SP.spfa());//注意最终结果是d[max_v]-d[9]的值,而不是d[max_v]的单独值
return 0;
}