数学--数论--hdu 6216 A Cubic number and A Cubic Number (公式推导)

2020-11-05 18:52:16 浏览数 (1)

代码语言:javascript复制
A cubic number is the result of using a whole number in a multiplication three times. 
For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125. 
Given an prime number p. Check that if p is a difference of two cubic numbers.

Input

代码语言:javascript复制
The first of input contains an integer T (1≤T≤100) which is the total number of test cases.
For each test case, a line contains a prime number p (2≤p≤1012).
Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.

Sample Input

代码语言:javascript复制
10
2
3
5
7
11
13
17
19
23
29

Sample Output

代码语言:javascript复制
NO
NO
NO
YES
NO
NO
NO
YES
NO
NO
代码语言:javascript复制
#include <bits/stdc  .h>
using namespace std;
typedef long long ll;
using namespace std;
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        ll n;
        scanf("%lld", &n);
        if ((n - 1) % 3)
        {
            printf("NOn");
            continue;
        }
        ll x = (ll)sqrt((n - 1) / 3);
        if (x * (x   1) == (n - 1) / 3)
            printf("YESn");
        else
            printf("NOn");
    }
    return 0;
}

0 人点赞