Problem Description
代码语言:javascript复制When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j i j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
Input
代码语言:javascript复制The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).
Output
代码语言:javascript复制For each case, output the number of ways in one line.
Sample Input
代码语言:javascript复制2
1
3
Sample Output
代码语言:javascript复制0
1
代码语言:javascript复制#include <bits/stdc .h>
using namespace std;
typedef long long ll;
using namespace std;
int main(){
int t;
long long n,i,j,ans;
scanf ("%d",&t);
while (t--){
ans=0;
scanf ("%lld",&n);
n ;
for (i=2;i*i<=n;i ){
if (n%i==0)
ans ;
}
printf ("%lldn",ans);
}
return 0;
}