数学--数论--HDU 2674 沙雕题

2020-11-06 00:19:51 浏览数 (1)

WhereIsHeroFrom: Zty, what are you doing ? Zty: I want to calculate N!.. WhereIsHeroFrom: So easy! How big N is ? Zty: 1 <=N <=1000000000000000000000000000000000000000000000… WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao? Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)! Input Each line will contain one integer N(0 <= N<=10^9). Process to end of file. Output For each case, output N! mod 2009 Sample Input 4 5 Sample Output 24 120

代码语言:javascript复制
import java.util.Scanner;

public class Main {
	static int ppp[]=new int [3000];
	static void init() {
		ppp[0]=ppp[1]=1;
		for(int i=1;i<=2009;i  ) 
			ppp[i]=(ppp[i-1]*i) 09;
	}
	public static void main(String[] args) {
  
		    init();
		    int l;
		    Scanner in = new Scanner(System.in);
		    while(in.hasNext()){
		    	l=in.nextInt();
		        if(l>=2009)
		            System.out.println(0);
		        else
		        	System.out.println( ppp[l]);
		    }
		}
}

0 人点赞