Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab programming contest abcd mnp
Sample Output
4 2 0
解题思路:
设MaxLen(i,j)表示:s1的左边i个字符形成的子串,与s2左边的j个字符形成的子串的最长公共子序列的长度(i,j从0开始算)MaxLen(i,j) 就是本题的“状态” 假定 len1 = strlen(s1),len2 = strlen(s2)那么题目就是要求 MaxLen(len1,len2)显然: MaxLen(n,0) = 0 ( n= 0…len1) MaxLen(0,n) = 0 ( n=0…len2) 递推公式: if ( s1[i-1] == s2[j-1] ) //s1的最左边字符是s1[0] MaxLen(i,j) = MaxLen(i-1,j-1) 1; else MaxLen(i,j) = Max(MaxLen(i,j-1),MaxLen(i-1,j) );
AC代码:
代码语言:javascript复制#include <iostream>
#include <string>
using namespace std;
string str1;
string str2;
int Max(int a , int b)
{
return (a>b)?a:b;
}
int main()
{
while(cin>>str1>>str2){
int len1 = str1.length();
int len2 = str2.length();
int MaxLen[len1 1][len2 1];
for ( int i = 0 ; i <= len1 ; i ){
MaxLen[i][0] = 0;
}
for ( int i = 0 ; i <= len2 ; i ){
MaxLen[0][i] = 0;
}
for ( int i = 1 ; i <= len1 ; i ){
for ( int j = 1 ; j <= len2 ; j ){
if ( str1[i-1] == str2[j-1]){
MaxLen[i][j] = MaxLen[i-1][j-1] 1;
}else{
MaxLen[i][j] = Max(MaxLen[i][j-1],MaxLen[i-1][j]);
}
}
}
cout<<MaxLen[len1][len2]<<endl;
}
return 0;
}