1054. 求平均值 (20)

2020-04-20 17:23:36 浏览数 (1)

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1: 7 5 -3.2 aaa 9999 2.3.4 7.123 2.35 输出样例1: ERROR: aaa is not a legal number ERROR: 9999 is not a legal number ERROR: 2.3.4 is not a legal number ERROR: 7.123 is not a legal number The average of 3 numbers is 1.38 输入样例2: 2 aaa -9999 输出样例2: ERROR: aaa is not a legal number ERROR: -9999 is not a legal number The average of 0 numbers is Undefined

代码语言:javascript复制
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
using namespace std;

int N;
char str[100][100]; 

bool Check(char s[])
{
    int i = 0;

    if(s[0] == '-')
    {
        i   ;
    }

    //整数部分检测,只能是数字 
    for(; s[i] && s[i] != '.'; i   ){
        if(!isdigit(s[i])){
            return false;
        }
    }

    //小数部分检测,只能是不超过2位的数字
    if(s[i] == '.'){
        for(int j = i   1; s[j]; j   ){
            if(!isdigit(s[j]) || j - i > 2){
                return false;
            }
        }
    }

    double a = fabs(atof(s));
    //范围检测
    if(a > 1000.0)
        return false;

    return true;
}

void solve()
{
    int ans = 0;
    double sum = 0;

    for(int i = 0; i < N; i   ){
        if(Check(str[i])){
            ans   ;
            sum  = atof(str[i]);
        }
        else{
            cout << "ERROR: " << str[i] << " is not a legal number" << endl;
        }
    }

    if(ans){
        if(ans == 1)
            printf("The average of 1 number is %.2lfn", sum);
        else
            printf("The average of %d numbers is %.2lfn", ans, sum / ans);

    }
    else{
        cout << "The average of 0 numbers is Undefined" << endl;
    }
}

int main()
{
    cin >> N;
    for(int i = 0; i < N; i   ){
        cin >> str[i]; 
    }
    solve();
    return 0;
}

0 人点赞