旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及坏掉的那些键,打出的结果文字会是怎样?
输入格式:
输入在2行中分别给出坏掉的那些键、以及应该输入的文字。其中对应英文字母的坏键以大写给出;每段文字是不超过105个字符的串。可用的字符包括字母[a-z, A-Z]、数字0-9、以及下划线“_”(代表空格)、“,”、“.”、“-”、“ ”(代表上档键)。题目保证第2行输入的文字串非空。
注意:如果上档键坏掉了,那么大写的英文字母无法被打出。
输出格式:
在一行中输出能够被打出的结果文字。如果没有一个字符能被打出,则输出空行。
输入样例: 7 IE. 7_This_is_a_test. 输出样例: _hs_s_a_tst
代码语言:javascript复制#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int hashtable[150] = {};
int i, j;
char s1[100010], s2[100010], c;
gets(s1);
gets(s2);
int len1, len2;
len1 = strlen(s1);
len2 = strlen(s2);
for(i = 0; i < len1; i )
{
c = s1[i];
hashtable[c] = 1;
}
for(i = 0; i < len2; i )
{
c = s2[i];
if(hashtable[' '] == 1 && c >= 'A' && c <= 'Z')
continue;
if(hashtable[c] == 1)
continue;
if(c >= 'a' && c <= 'z' && hashtable[c 'A' - 'a'] == 1)
continue;
printf("%c", c);
}
printf("n");
return 0;
}