以上图片来自新浪微博。
本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
- 无论用户说什么,首先把对方说的话在一行中原样打印出来;
- 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
- 把原文中所有大写英文字母变成小写,除了
I
; - 把原文中所有独立的
can you
、could you
对应地换成I can
、I could
—— 这里“独立”是指被空格或标点符号分隔开的单词; - 把原文中所有独立的
I
和me
换成you
; - 把原文中所有的问号
?
换成惊叹号!
; - 在一行中输出替换后的句子作为 AI 的回答。
输入描述:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出描述:
按题面要求输出,每个 AI 的回答前要加上 AI:
和一个空格。
输入样例:
代码语言:javascript复制6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
代码语言:javascript复制Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
解题思路:
这是去年天梯赛L1级别的最后一题,当时硬做没有写出来。这题用C 的regex库来求解会比较简单,正则表达式还是牛逼嗷。替换的时候需要注意.和?前需要加 ,而 又是转义字符,所以得在.和?前加 \,b是用于判断是否为独立的单词,s是用来判断是否为空白符,它们前面的都需要再加一个进行转义。我用了regex求解之后测试样例没有问题,提交之后有个3分的测试点过不了,找了很久的bug之后发现必须得先把can you和could you替换成I can和I could后再替换I和me,而且替换过后的I can和I could里面的I不能够在 I 换成you的时候再次进行替换。所以我先把can you和could you替换成了_I can和_I could,等到I和me都替换成you之后再把_I替换回 I 。
17分代码:
代码语言:javascript复制#include <bits/stdc .h>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0),cout.tie(0);
int n;
cin >> n;
cin.ignore();
while(n--)
{
string str;
getline(cin,str);
cout << str << endl; //输出用户的原话
cout << "AI: ";
str = regex_replace(str,regex("\s ")," "); //删除连续的多余空格
str = regex_replace(str,regex(" ,"),","); //删除,前的空格
str = regex_replace(str,regex(" \."),"."); //删除.前的空格
str = regex_replace(str,regex(" !"),"!"); //删除!前的空格
str = regex_replace(str,regex(" \?"),"?"); //删除?前的空格
str = regex_replace(str,regex(" '"),"'"); //删除'前的空格
if(str.front()==' ') str.erase(str.begin()); //删除字符串行首的空格
if(str.back()==' ') str.pop_back(); //删除字符串行末的空格
for(auto &it : str)
{
//把所有除I外的大写字母转小写
if(isupper(it) && it!='I')
{
it = tolower(it);
}
}
str = regex_replace(str,regex("\?"),"!"); //替换所有的?为!
str = regex_replace(str,regex("\bI\b"),"you"); //替换所有的独立的I为you
str = regex_replace(str,regex("\bme\b"),"you"); //替换所有的独立的me为you
str = regex_replace(str,regex("\bcan you\b"),"I can"); //替换所有的can you为I can
str = regex_replace(str,regex("\bcould you\b"),"I could"); //替换所有的could you为I could
cout << str << endl;
}
return 0;
}
AC代码:
代码语言:javascript复制#include <bits/stdc .h>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0),cout.tie(0);
int n;
cin >> n;
cin.ignore();
while(n--)
{
string str;
getline(cin,str);
cout << str << endl; //输出用户的原话
str = regex_replace(str,regex("\s ")," "); //删除连续的多余空格
str = regex_replace(str,regex(" ,"),","); //删除,前的空格
str = regex_replace(str,regex(" \."),"."); //删除.前的空格
str = regex_replace(str,regex(" !"),"!"); //删除!前的空格
str = regex_replace(str,regex(" \?"),"?"); //删除?前的空格
str = regex_replace(str,regex(" '"),"'"); //删除'前的空格
if(str.front()==' ') str.erase(str.begin()); //删除字符串行首的空格
if(str.back()==' ') str.pop_back(); //删除字符串行末的空格
for(auto &it : str)
{
//把所有除I外的大写字母转小写
if(isupper(it) && it!='I')
{
it = tolower(it);
}
}
str = regex_replace(str,regex("\?"),"!"); //替换所有的?为!
str = regex_replace(str,regex("\bcan you\b"),"_I can"); //替换所有的can you为_I can
str = regex_replace(str,regex("\bcould you\b"),"_I could"); //替换所有的could you为_I could
str = regex_replace(str,regex("\bI\b"),"you"); //替换所有的独立的I为you
str = regex_replace(str,regex("\bme\b"),"you"); //替换所有的独立的me为you
str = regex_replace(str,regex("\b_I\b"),"I"); //为了避免重复替换而设置的_I换回I
//必须先换can you/could you再换I和mem,不然有一个测试点一直卡3分
cout << "AI: " << str << endl;
}
return 0;
}