1030 完美数列 (25 分)
给定一个正整数数列,和正整数 p,设这个数列中的最大值是 M,最小值是 m,如果 M≤mp,则称这个数列是完美数列。
现在给定参数 p 和一些正整数,请你从中选择尽可能多的数构成一个完美数列。
输入格式:
输入第一行给出两个正整数 N 和 p,其中 N(≤105)是输入的正整数的个数,p(≤109)是给定的参数。第二行给出 N 个正整数,每个数不超过 109。
输出格式:
在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。
输入样例:
代码语言:javascript复制10 8
2 3 20 4 5 1 6 7 8 9
输出样例:
代码语言:javascript复制8
我的代码
代码语言:javascript复制// 1030 完美数列 (25 分).cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(int a, int b) {
return a < b;
}
int main() {
//输入
int input, p;
cin >> input >> p;
vector<double> input_total;
double tmp;
for (int i = 0; i < input; i ) {
cin >> tmp;
input_total.push_back(tmp);
}
//排序
sort(input_total.begin(), input_total.end(), cmp);
//从最大值开始往前循环
int max_index = input_total.size() - 1;
int res = 0, cnt = 0;
int j;
for (int i = 0; i < input_total.size(); i ) {
//把当前i作为最小值
tmp = input_total[i] * p;
for (j = cnt; j < input_total.size(); j ) {
if (input_total[j] > tmp)
break;
if (j - i >= res)
res = j - i 1;
}
cnt = j;
}
cout << res;
}
思路
首先要对输入进行排序,然后从最小值开始,每个最小值找到对应的最大值,看看vector中是否存在满足最大值的数。若存在,则获取最大值索引,比较res,若大于res则更新res,若小于res,就下一次遍历即可。