1081 检查密码 (15 分)

2019-11-11 18:20:03 浏览数 (1)

1081 检查密码 (15 分)

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

代码语言:javascript复制
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

代码语言:javascript复制
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

【我的代码】

代码语言:javascript复制
//1081 检查密码 (15 分)
#include <iostream>
#include <string>
using namespace std;
int main(){
    int N;
    cin>>N;
    getchar();
    string tmp;
    int len;
    bool flag_num = false;
    bool flag_zimu = false;
    bool flag_feifa = false;
    for(int i = 0; i < N; i  ){
        bool flag_num = false;
        bool flag_zimu = false;
        bool flag_feifa = false;
        getline(cin, tmp);
        len = tmp.length();
        for(int j = 0; j < len; j  ){
            if(tmp[j] >= '0' && tmp[j] <= '9')
                flag_num = true;//数字 
            else if((tmp[j] >= 'a' && tmp[j] <= 'z') || (tmp[j] >= 'A' && tmp[j] <= 'Z'))
                flag_zimu = true;//字母
            else if(tmp[j] == '.')
                continue;//小数点可以继续 
            else{
                flag_feifa = true;//非法字符串               
            }
        }
        if(len < 6)
            cout<<"Your password is tai duan le."<<endl;
        else if(flag_feifa)
            cout<<"Your password is tai luan le."<<endl;
        else if(flag_num && !flag_zimu)
            cout<<"Your password needs zi mu."<<endl;
        else if(flag_zimu && !flag_num)
            cout<<"Your password needs shu zi."<<endl;
        else{
            cout<<"Your password is wan mei."<<endl;
        }   
    }
    return 0;
}

【总结】

题目难度不大,逐个判断即可,需要注意的是,cin读到换行符和空格就结束(也就是测试点2,应该是包含了空格的输入),因此需要使用getline,但是需要注意的是,getline前需要getchar读取一个换行符。

0 人点赞